WordPress obecně

WordPress 4.9.1

Autor příspěvku Tomáš Cirkl

WordPress 4.9.1 byl uvolněn k aktualizaci. Jedná se o bezpečnostní aktualizaci, která by měla proběhnout automaticky. Pokud tomu však u vašeho WordPress webu není, důrazně doporučujeme aktualizaci provést co nejdříve.

Ve verzi 4.9.1. byly nalezeny čtyři bezpečnostní chyby, které nová aktualizace opravuje.

  1. Správné generovaní hash klíče pro newsblogger namísto vytvoření řetězce.
  2. Ukončení parametrů jazyka při použití html elementu.
  3. Přidání zajištění ukončení atributů v RSS a Atom.
  4. Odstranění možnosti nahrát JavaScriptové soubory pro uživatele, kteří nemají schopnost unfiltered_html.

Mimo to bylo opraveno dalších jedenáct chyb. Jedná se například o:

  • Problémy způsobené cachováním souborů šablony.
  • JavaScriptová chyba, která způsobovala nemožnost nahrát mediální soubor uživatelům s určitým nastavením jazyka.
  • Nemožnost upravovat soubory v šabloně nebo pluginu na serverech využívající Windows.

Seznam všech oprav najdete na oficiálních stránkách.

WordPress 4.9.1 si můžete stáhnout z oficiálních stránek nebo provést aktualizaci v administraci WordPress v sekci Nástěnka -> Aktualizace.

O autorovi

Tomáš Cirkl

Baví mě Internet a zvláště pak redakční systém WordPress. Jsem pravidelným účastníkem a přednášejícím na WordCamp Praha a WordPress konferencích.

17 komentářů

  • Mě se včera večer automaticky aktualizoval web na v. 4.8.4. Verze 4.9.1 je anglická, když jí nainstaluji, neodstřihnu se tím do budoucna od češtiny, až vyjde 4.9.1 v češtině?

    • Verze 4.8.4 se vám nainstalovala, protože WordPress vývojáři poskytují podporu i několika verzím zpět. Proto, když se najde chyba, tak ji opraví i na starších verzích. Nicméně vždy doporučuji aktualizovat na nejnovější verzi. O češtinu nepřijdete, maximálně nebudete mít nové texty ve WordPress přeložené, ale vše jinak zůstane.

  • Zdravím vás,
    prosím o radu. Mám na NASu od Zyxel WordPress 3.6.1 a zaboha to nemůžu zaktualizovat/přeinstalovat. Máte s tím prosím nějaké zkušenosti?

      • ono to moc chyb nepíše. Kliknu na “tools” a v pravo dole na “get version 4.9.1”. Poté se mi na strance ukáže “Last checked on 08/12/2017 at 13:08. Check Again

        While your site is being updated, it will be in maintenance mode. As soon as your updates are complete, your site will return to normal.”…. Dovolí mi to aktualizovat pouze pluginy a téma

        • Případně můžete zkusit manuální aktualizaci jádra. Nicméně doporučuji udělat kompletní zálohu.

  • jsem amatér začátečník. Zatím není co zálohovat. Nejdříve tam potřebuji dostat nějakou novější verzi, poté češtinu a hurá na psaní 🙂

  • návod jdu zkusit, děkuji. Rád bych to jen mázl a nahrál něco nového ale není to jen tak. V NASu se instalují balíčky s koncovkou “zpkg”, zkoušel jsem najít novější verze s touto příponou ale nenašel a když kouknu do složky wordpress mam tam pouze “plugins” “themes” “uploads” i po zobrazení skrytých složek :/

  • Při aktualizaci na anglickou verzi WordPress 4.9.1 mi přestalo v části přizpůsobit fungovat ovládání barev šablony. Šablona je zakoupená na Themeforest. Myslel jsem si, že chybu opraví, a proto je dnes přeinstaloval na českou verzi 4.9.1 a bohužel problém nevyřešen. Máte nějakou radu prosím?

  • Aktualizoval jsem na verzi 4.9.1 a přestalo mi fungovag v editaci příspěvků tlačítku mediální soubor a html. Pokud kliknu na přidání náhledového obrázku, oběví se značně omezená galerie s řádkovým výpisem oproti standardní náhledové. Tušíte kde je problém?

    • Zkuste načíst stránku pomocí CTRL+F5. Případně se koukněte do konzole, jestli tam není nějaká chyba.

      • Javascript me napadl, jenze netusim kde a co s tím…
        Nasel jsme tyhle chyby:
        [Error] TypeError: undefined is not a function (near ‘…a.widget…’)
        (anonymní funkce) (load-scripts.php:35:145)
        (anonymní funkce) (load-scripts.php:35:108)
        Globální kód (load-scripts.php:35:117)
        [Error] TypeError: undefined is not a constructor (evaluating ‘new QTags(a)’)
        quicktags (load-scripts.php:701)
        (anonymní funkce) (post.php:2306)
        Globální kód (post.php:2313)
        [Error] TypeError: undefined is not a function (near ‘…jQuery(‘.ilentheme-options #tabs,.ilenplugin-options #tabs’)
        .tabs…’)
        (anonymní funkce) (core.js:4)
        fire (jquery_1.8.3.js:974)
        fireWith (jquery_1.8.3.js:1084)
        ready (jquery_1.8.3.js:406)
        DOMContentLoaded (jquery_1.8.3.js:83)

      • Tak problém je v šabloně… Je nějaká historická, kdyby Vás napadlo na co se podívat… Jinak budu přemýšlet jak použít nějakou novou a jak ji upravit…

        Díky moc za navedení.

        • Ano, nejspíše tam bude nekompatibilita ze strany šablony nebo pluginu. Koukněte, kdy byla šablona naposled aktualizována, jinak bych doporučil změnu.

Zanechat komentář

Získejte více informací o WordPress!

Připojte se do našeho emailového seznamu a nenechte si ujít informace, novinky a návody ze světa WordPressu.

Úspěšně jste se zapsali do našeho newsletteru. Děkujeme!

Tomáš Cirkl

Tomáš Cirkl

WordPress specialista

Blog WPlama.cz píši už více než 3 roky. O WordPress přednáším a pořádám školení. Pro své klienty vytvářím a spravuji webové stránky.